v1.7.0.12 Release

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
Post Reply
User avatar
garyan2

Posts: 6577
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

v1.7.0.12 Release

#1

Post by garyan2 » Thu Dec 16, 2021 1:57 am

Just released a new version to address the errors in json returns from SD causing a lot of folks to fail to update their guide data.
- Gary
Keeping WMC alive beyond January 2020. https://garyan2.github.io

Space

Posts: 2532
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#2

Post by Space » Thu Dec 16, 2021 4:09 am

Have you been in contact with SD to figure out why this has happened? Did they release a new version of their server software that violates their own API?

rkulagow

Posts: 245
Joined: Sun Jul 19, 2015 1:04 am
Location: Schedules Direct

HTPC Specs: Show details

#3

Post by rkulagow » Thu Dec 16, 2021 5:09 am

(I work for Schedules Direct)

This has been raised to our upstream; they are sending invalid data to all of their customers for certain stationIDs. Our ingest code actually "caught" the error, just in the wrong way, because back in the ancient mists of time the broadcastLanguage field was a comma separated string, rather than a JSON array, so when we received stationIDs that didn't have the data, the code tried to correct it, but replaced the empty upstream data with a string of "en", rather than an array with a single element of "en".

The stations and lineups are being rebuilt now, and I've opened a high-priority ticket with our upstream.

bsyd

Posts: 7
Joined: Tue Mar 18, 2014 4:15 pm
Location:

HTPC Specs: Show details

#4

Post by bsyd » Thu Dec 16, 2021 4:58 pm

This new version took care of the problem for me. Thanks for the quick fix Gary.
-Bob

User avatar
IT Troll

Posts: 1002
Joined: Sun Nov 27, 2011 9:42 am
Location: Edinburgh, UK

HTPC Specs: Show details

#5

Post by IT Troll » Sat Dec 18, 2021 9:33 am

Thanks. The issue didn't manifest on my lineup, but I still updated anyway.
Are you a Recorded TV HD user or want to give it a try? Check out the new community-made update; Recorded TV HD v2.1.1

Post Reply