EPG working but not showing in WMC

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
Post Reply

Posts: 12
Joined: Thu Apr 09, 2020 12:57 am
Location: Rockaway, NJ

HTPC Specs: Show details

EPG working but not showing in WMC


Post by proboscis » Thu Feb 02, 2023 3:08 am

Hi all, i've been using EPG for a few years and it's been working great on a physical PC. Now I've set up WMC on a VM and I'm not getting the listings in WMC even though it looks like EPG is set up correctly. Any ideas what it could be? I've re-run the client setup several times and it goes through clean. Thanks!


User avatar

Posts: 6991
Joined: Fri Nov 27, 2015 7:23 pm

HTPC Specs: Show details


Post by garyan2 » Thu Feb 02, 2023 3:11 am

Click the Match by: [# Number] button.

Sent from my SM-G781U1 using Tapatalk

- Gary
Keeping WMC alive beyond January 2020. https://garyan2.github.io


Posts: 2667
Joined: Sun Jun 02, 2013 9:44 pm

HTPC Specs: Show details


Post by Space » Thu Feb 02, 2023 1:25 pm

You also may want to delete your scheduled task (upper left corner of the EPG123 client), change it to something other than a time ending in :00, such as 06:20 (to make it less likely to encounter a busy server due to others also choosing the same time), check the box next to "Automatch" (so that any channels add/removed/changed from your lineup automatically show up in WMC), and then create the scheduled task again.


Posts: 142
Joined: Wed Feb 25, 2015 2:38 am

HTPC Specs: Show details


Post by eclas » Wed Feb 08, 2023 4:18 pm

Old issue here but I can't figure it out. My guide is missing channels that are selected in epg. They show up in the config and also in the client on both sides. I tried deleting the 'orpahaned' channels as that worked the last time something similar happened but it didn't work this time.
I tried rebuilding the database also.
Any ideas on what else to try?
What about if I totally deleted everything related to epg on my system and reinstalled?

Post Reply