ModernMedia UI+ - Modern Theme and All-New Features

User avatar
IT Troll

Posts: 830
Joined: Sun Nov 27, 2011 9:42 am
Location: Edinburgh, UK

HTPC Specs: Show details

Re: ModernMedia UI+ - Modern Theme and All-New Features

#221

Post by IT Troll » Wed Jan 01, 2020 11:45 pm

Great news! I will give this another test on my test VM with a view to buying a copy for my live system. I’ve been watching with interest since the initial release and it sounds like v1.2 has addressed many of the outstanding issues.
Are you a Recorded TV HD user or want to give it a try? Check out the new community-made update; Recorded TV HD v2.1.1

User avatar
IT Troll

Posts: 830
Joined: Sun Nov 27, 2011 9:42 am
Location: Edinburgh, UK

HTPC Specs: Show details

#222

Post by IT Troll » Thu Jan 02, 2020 5:38 pm

I spent some time with MM UI+ in my test VM and I am still seeing some of the old original blue theme.

Blue text in View Song List (Music)
Old focus icons on play all and search (Music)
Blue text in Search (Music)
Old focus icons on play slide show (Picture Library)
Old focus icons on play all (Video Library)
Blue text throughout Settings
Blue menu transition effect in Settings
Old focus icon for Burn CD/DVD

Blue tint on inactive items on custom strips. I believe this tint colour is baked into the Media Center code. The trouble is, it creates a mismatch with the standard menu strips in this theme. One workaround would be to tint the standard menu strips so that they match the colour of the custom strip.

Whilst exploring Settings I found I would consistently experience a crash to desktop if I selected; Settings > General > Startup and Window Behaviour

I noticed that sometimes the Weather text is obscured by the time.
Attachments
BlueBits.png
Are you a Recorded TV HD user or want to give it a try? Check out the new community-made update; Recorded TV HD v2.1.1

User avatar
IT Troll

Posts: 830
Joined: Sun Nov 27, 2011 9:42 am
Location: Edinburgh, UK

HTPC Specs: Show details

#223

Post by IT Troll » Sat Jan 04, 2020 6:41 pm

I have now been able to test out the new guide and I must say it is very impressive! I think it will make it to my live system. I have found some more of the old original blue theme. Perhaps this is intentional? But I think I will have to re-theme these and the above elements:

Old focus icons on add recording and view scheduled (Recorded TV)
Blue text in Search (TV)
Blue text in Record Settings, View Scheduled, Series, History, etc.

I am finding that I am not getting the Rotten Tomatoes scores or content ratings. I have all the metadata options ticked (and no theme mods enabled).
Attachments
Movie2.png
Movie1.png
Are you a Recorded TV HD user or want to give it a try? Check out the new community-made update; Recorded TV HD v2.1.1

User avatar
IT Troll

Posts: 830
Joined: Sun Nov 27, 2011 9:42 am
Location: Edinburgh, UK

HTPC Specs: Show details

#224

Post by IT Troll » Thu Jan 09, 2020 1:32 am

Here is a list of the image resources which got missed and show elements of the original theme.

AUDIO.TRACKPLAYING.BAR.PNG
AUDIO.TRACKPLAYING.GRID.PNG
AUDIO.TRACKPLAYING.MASK.PNG
BROWSE.CMD.ADD.FOCUS.PNG
BROWSE.CMD.PLAY.FOCUS.PNG
BROWSE.CMD.SEARCH.FOCUS.PNG
BROWSE.CMD.SCHEDULED.FOCUS.PNG
EPG.CATEGORY.HIGHLIGHT.PNG
EPG.CATEGORY.LINE.PNG
STARTMENU.QUICKLINK.BURNCD.FOCUS.PNG
Are you a Recorded TV HD user or want to give it a try? Check out the new community-made update; Recorded TV HD v2.1.1

User avatar
W10MC

Posts: 122
Joined: Mon Aug 01, 2016 7:45 am
Location:

HTPC Specs: Show details

#225

Post by W10MC » Thu Jan 09, 2020 5:15 pm

IT Troll wrote:
Thu Jan 02, 2020 5:38 pm
I am still seeing some of the old original blue theme.
Yes, some of the blue elements remain. It has been difficult to track down the source of some items. In addition, most of the remaining blue text seems to be located in locale-specific files, which requires editing additional resources to make changes.
IT Troll wrote:
Thu Jan 02, 2020 5:38 pm
I would consistently experience a crash to desktop if I selected; Settings > General > Startup and Window Behaviour
The crash may be a result of testing in a VM as I do not experience this behavior in a normal desktop environment.
IT Troll wrote:
Thu Jan 02, 2020 5:38 pm
I noticed that sometimes the Weather text is obscured by the time.
When running in a 4:3 aspect ratio, the reduced margins can cause the text to be cut off; it appears correctly in 16:9. This will be fixed in the next update.
IT Troll wrote:
Sat Jan 04, 2020 6:41 pm
I am not getting the Rotten Tomatoes scores or content ratings.
This appears to be broken again. It will be fixed in the next release.
-Mike

Windows 10 Media Center Community
An independent project for media application development.

User avatar
IT Troll

Posts: 830
Joined: Sun Nov 27, 2011 9:42 am
Location: Edinburgh, UK

HTPC Specs: Show details

#226

Post by IT Troll » Thu Jan 09, 2020 6:24 pm

W10MC wrote:
Thu Jan 09, 2020 5:15 pm
Yes, some of the blue elements remain. It has been difficult to track down the source of some items. In addition, most of the remaining blue text seems to be located in locale-specific files, which requires editing additional resources to make changes.
Could be something like that. I am based in the UK and so my locale will be en-gb. I know Media Center Themer substitutes resources in a number of files e.g. ehres.dll, microsoft.mediacenter.shell.dll, microsoft.mediacenter.ui.dll, startresources.dll
W10MC wrote:
Thu Jan 09, 2020 5:15 pm
The crash may be a result of testing in a VM as I do not experience this behavior in a normal desktop environment.
Maybe, it doesn't crash on a VM without ModernMedia UI+ though.
W10MC wrote:
Thu Jan 09, 2020 5:15 pm
When running in a 4:3 aspect ratio, the reduced margins can cause the text to be cut off; it appears correctly in 16:9. This will be fixed in the next update.
Yeah, I worked that out after posting. I would imagine most real systems will be 16:9.
Are you a Recorded TV HD user or want to give it a try? Check out the new community-made update; Recorded TV HD v2.1.1

User avatar
IT Troll

Posts: 830
Joined: Sun Nov 27, 2011 9:42 am
Location: Edinburgh, UK

HTPC Specs: Show details

#227

Post by IT Troll » Mon Apr 13, 2020 10:37 am

Has Rotten Tomatoes and content ratings been fixed yet?
Are you a Recorded TV HD user or want to give it a try? Check out the new community-made update; Recorded TV HD v2.1.1

User avatar
W10MC

Posts: 122
Joined: Mon Aug 01, 2016 7:45 am
Location:

HTPC Specs: Show details

#228

Post by W10MC » Tue Apr 14, 2020 2:30 am

IT Troll wrote:
Mon Apr 13, 2020 10:37 am
Has Rotten Tomatoes and content ratings been fixed yet?
Not yet.
-Mike

Windows 10 Media Center Community
An independent project for media application development.

User avatar
W10MC

Posts: 122
Joined: Mon Aug 01, 2016 7:45 am
Location:

HTPC Specs: Show details

#229

Post by W10MC » Sat Sep 05, 2020 5:00 am

Version 1.3 of ModernMedia UI+ has been released along with a new resource build (200904). This release restores Rotten Tomatoes scores once again. In addition, it includes a brand new section for advanced options available on activated installations. This is a highly recommended update!

Here are the new options (details are listed on the UI+ product page):
1. Override Tuner Limits for TV Signal Setup
2. Ignore EAS Force-Tune Requests (U.S. only)
3. Disable Volume Display Overlay
4. Use Maximum Brightness for Captions Text
5. Always List Closed Captioning Options in Settings
6. Remove Blue Tint from Start Menu Tiles
7. Disable Prompt to Download Guide Listings
8. Preserve Window State on External App Launch
9. Suppress Errors on External App Launch

The new build also offers numerous enhancements:
1. Overscan has been removed from video playback in windowed mode during and after the display of a message announcement screen.
2. Weather text will no longer be cut off on the Start menu when viewed in a 4:3 aspect ratio.
3. Channel entry input has been increased to 9 digits in the program guide as well as in video playback.
4. Visibility of teletext-based subtitles can now be adjusted like captions and regular subtitles when using the custom keyboard shortcut (Shift+C).
5. A DOLBY+ indicator is now shown in the info bar if the current media contains a Dolby Digital Plus audio stream (only applies to live and recorded TV).
6. Additional audio channel layouts and sample rates are now supported in the info bar.
7. Channel logos will attempt to be located automatically in the info hinting bar if not present in program metadata.
8. Changes have been made to the implementation of EAS messages (U.S. only), enabling functionality of the seekbar, info bar, mini-guide, and digit entry during an alert; an option has also been added to hide the EAS information bar in the UI+ settings.
-Mike

Windows 10 Media Center Community
An independent project for media application development.

User avatar
aquadextrous

Posts: 80
Joined: Mon Jul 30, 2018 8:09 pm
Location: Bristol, UK

HTPC Specs: Show details

#230

Post by aquadextrous » Sun Sep 06, 2020 11:00 am

Hi Mike, thanks for the update :)

When I hit update resources i get an error message the details are:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Net.WebException: The request was aborted: Could not create SSL/TLS secure channel.
at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
at System.Net.Http.HttpClientHandler.GetResponseCallback(IAsyncResult ar)


It gives an option of continue or quit - hitting continue returns to MMUI+ but it does nothing and quit force closes it. Not sure if it's just me / something on my system stopping it or if anyone else is having the same thing? OTher included features like the re-addition of rotten tomatoes and extended movie information do work as normal. :)

Thanks

Anthony

EDIT:
Found a solution online, seems to be something with .net not being configured properly - anyone with the same issue add the below into Regedit:

Code: Select all

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319] "SchUseStrongCrypto"=dword:00000001 
 
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319] "SchUseStrongCrypto"=dword:00000001
Adding the above to the registry and rebooting worked for me but YMMV.

User avatar
W10MC

Posts: 122
Joined: Mon Aug 01, 2016 7:45 am
Location:

HTPC Specs: Show details

#231

Post by W10MC » Sun Sep 06, 2020 6:30 pm

aquadextrous wrote:
Sun Sep 06, 2020 11:00 am
When I hit update resources i get an error message
Thank you for the report. This issue does not appear to affect every system, but I have reuploaded the installer with a small fix to automatically support newer security protocols when downloading resources.
-Mike

Windows 10 Media Center Community
An independent project for media application development.

Paint

Posts: 93
Joined: Mon Apr 04, 2016 4:37 am
Location:

HTPC Specs: Show details

#232

Post by Paint » Sun Sep 06, 2020 6:37 pm

aquadextrous wrote:
Sun Sep 06, 2020 11:00 am
Hi Mike, thanks for the update :)

When I hit update resources i get an error message the details are:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Net.WebException: The request was aborted: Could not create SSL/TLS secure channel.
at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
at System.Net.Http.HttpClientHandler.GetResponseCallback(IAsyncResult ar)


It gives an option of continue or quit - hitting continue returns to MMUI+ but it does nothing and quit force closes it. Not sure if it's just me / something on my system stopping it or if anyone else is having the same thing? OTher included features like the re-addition of rotten tomatoes and extended movie information do work as normal. :)

Thanks

Anthony

EDIT:
Found a solution online, seems to be something with .net not being configured properly - anyone with the same issue add the below into Regedit:

Code: Select all

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319] "SchUseStrongCrypto"=dword:00000001 
 
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319] "SchUseStrongCrypto"=dword:00000001
Adding the above to the registry and rebooting worked for me but YMMV.
Thank you! Adding these two registry entries and rebooting the machine allowed me to update MMUI+

PeteS457

Posts: 43
Joined: Thu Mar 08, 2012 3:12 pm
Location:

HTPC Specs: Show details

#233

Post by PeteS457 » Tue Sep 08, 2020 11:41 pm

Well, I'm having a very negative installation experience. I downloaded the 1.3 from windows10mediacenter.com. Installed, it brought up the options/check box page. I added one check box about "Hide EAS Information Bar". I went up to Update Resources and I get the dialog warning with the Details/Continue/Quit. The only thing to do is hit Quit and it returns to the main options page. At that point the only thing you can do is hit the Close icon on the top right corner and I get another warning "It is not recommended to close this application while system files are being modified. Are you sure you want to quit?" Uggghhh. I have made the two suggested regedit modifications and rebooted. No difference in behavior. I have no idea what version is installed, if the system is stable or not.

Questions:

How do I know what version is installed, if 1.3 installed correctly or not?

What Resources Build is supposed to be installed?

Any help would be greatly appreciated. I have no idea what has been done to the installation or if anything has been done. Thanks.

User avatar
W10MC

Posts: 122
Joined: Mon Aug 01, 2016 7:45 am
Location:

HTPC Specs: Show details

#234

Post by W10MC » Wed Sep 09, 2020 5:15 am

PeteS457 wrote:
Tue Sep 08, 2020 11:41 pm
How do I know what version is installed, if 1.3 installed correctly or not?
You can click the "About" button in the app to verify the version.
PeteS457 wrote:
Tue Sep 08, 2020 11:41 pm
What Resources Build is supposed to be installed?
The latest resource build is 200904.
PeteS457 wrote:
Tue Sep 08, 2020 11:41 pm
Any help would be greatly appreciated. I have no idea what has been done to the installation or if anything has been done. Thanks.
Based on your description, the installation completed properly but no changes were actually made to system files or WMC since the resources could not be downloaded. The problem you are experiencing is that the OS is not allowing a secure connection using TLS 1.2 or higher between the application and the web server that hosts the resource files. Unfortunately, I cannot reproduce the error on Windows 7, 8.1 or 10 with the updated 1.3 installer, which was released a few days ago specifically to address this issue.
-Mike

Windows 10 Media Center Community
An independent project for media application development.

PeteS457

Posts: 43
Joined: Thu Mar 08, 2012 3:12 pm
Location:

HTPC Specs: Show details

#235

Post by PeteS457 » Wed Sep 09, 2020 3:03 pm

Well thanks for responding. But unfortunately this does not indicate what I should do to resolve my issues. If I can't update to the new build at this time, that's fine. But I would like to get my old installation back up and running as before. Here is the information that I can give you about my media center:
  • My machine is running Windows 7 x64, all Windows Updates applied and current. It only has 4 GB RAM, but the machine has been stable and runs well with no known issues. It basically has one function - to run WMC.
  • Clicking the MMUI+ About button confirms the installation is now 1.3 x64.
  • The Resources Build is still on 191231.
  • You stated that "no changes were actually made to system files or WMC since resources could not be downloaded". Well something has changed. WMC seems to be acting *mostly* the same as before, but the Sports and Weather strip no longer load information. Upon selection, they remain blank. That's a concern in the short term because I actually use both of those several times a day. (Although - on a side note - is there ANY way you can add college football and college basketball to the Sports strip? That would be so awesome.)
Just to give you as much information as possible, once again these two things happen when trying to get out of MMUI+ configuration setup:
  • Clicking on Update Resources, the dialog warning with the Details/Continue/Quit pops up. If you select Continue, it returns to the main options page and Update Resources is greyed out. If at that point you click the Close icon on the top right corner (or you selected Quit in the previous dialog), you get another warning "It is not recommended to close this application while system files are being modified. Are you sure you want to quit?"
  • If instead of clicking the Close icon you try to Save and Exit, you get a different dialog box. "Files updated by Windows Media Center must be updated in order to make selected changes. Any processes associated with Windows Media Center will be terminated at this time."
I do have a restore point from 3 days ago. Will this restore my previous functionality? Is this what you suggest I do? Is there a previous software build (e.g., MMUI+ 1.2) that I can reinstall? Are there settings to try to address the TLS issue? Thanks if you can help with any of these questions.

User avatar
W10MC

Posts: 122
Joined: Mon Aug 01, 2016 7:45 am
Location:

HTPC Specs: Show details

#236

Post by W10MC » Thu Sep 10, 2020 6:00 pm

Thanks for providing that information. Please download the installer and try again. I'm hopeful this latest fix will resolve the issue.
PeteS457 wrote:
Wed Sep 09, 2020 3:03 pm
is there ANY way you can add college football and college basketball to the Sports strip?
The sports data has previously included NCAA football, and college basketball may be included as well.
-Mike

Windows 10 Media Center Community
An independent project for media application development.

PeteS457

Posts: 43
Joined: Thu Mar 08, 2012 3:12 pm
Location:

HTPC Specs: Show details

#237

Post by PeteS457 » Thu Sep 10, 2020 8:41 pm

Well....thank you for the new installer. I have good news...and bad news.

I downloaded the new installer. All seemed to be going well. Upon install and launch, a dialog popped up immediately announcing the new build. The new build started automatically downloading, installing, and then it announced Update Complete and the new build 200904 was displayed. However from there, it was all downhill (unfortunately).

After the above update completes, I go to select Save and Exit from MMUI+. Once again as before I get the message "Files updated by Windows Media Center must be updated in order to make selected changes. Any processes associated with Windows Media Center will be terminated at this time." The application closes. When I then launch WMC, everything seems fine (I don't know if it's supposed to look different than the previous version but it looks the same). However, when I go to the Sports icon, a blank page comes up (it does have the word "Sports" in the upper left corner and the MSN logo bottom right and that's all). Even worse though is now the Weather icon briefly brings up the Weather page (one second) before crashing WMC. This behavior is consistently repeatable.

I guess this should be seen as a move forward. You have any other suggestions for me? Thanks for your help.

User avatar
W10MC

Posts: 122
Joined: Mon Aug 01, 2016 7:45 am
Location:

HTPC Specs: Show details

#238

Post by W10MC » Fri Sep 11, 2020 3:55 am

PeteS457 wrote:
Thu Sep 10, 2020 8:41 pm
when I go to the Sports icon, a blank page comes up (it does have the word "Sports" in the upper left corner and the MSN logo bottom right and that's all).
If you are not getting sports data in WMC, the background server is still unable to establish a secure connection.

Navigate to C:\Program Files\ModernMedia\UI+ and check the modification date of ModernMedia.Server.exe. The latest version will have a date of 9/10/20. Otherwise, an older version is in use. To update it, open UI+, click "Stop" to end the background server process, exit UI+ and delete ModernMedia.Server.exe from the folder. Run the installer again and ensure that ModernMedia.Server.exe has been extracted to the UI+ program folder. Finally, open UI+ to verify the server is running, and then check the Sports section in WMC.
-Mike

Windows 10 Media Center Community
An independent project for media application development.

User avatar
IT Troll

Posts: 830
Joined: Sun Nov 27, 2011 9:42 am
Location: Edinburgh, UK

HTPC Specs: Show details

#239

Post by IT Troll » Sat Sep 12, 2020 8:20 am

Why not offer a full offline installer option? The requirement to download a resource file at installation time from a remote server is a concern. Media Center users are all too familiar with such servers disappearing and never returning.
Are you a Recorded TV HD user or want to give it a try? Check out the new community-made update; Recorded TV HD v2.1.1

PeteS457

Posts: 43
Joined: Thu Mar 08, 2012 3:12 pm
Location:

HTPC Specs: Show details

#240

Post by PeteS457 » Wed Sep 16, 2020 3:41 pm

W10MC wrote:
Fri Sep 11, 2020 3:55 am
PeteS457 wrote:
Thu Sep 10, 2020 8:41 pm
when I go to the Sports icon, a blank page comes up (it does have the word "Sports" in the upper left corner and the MSN logo bottom right and that's all).
If you are not getting sports data in WMC, the background server is still unable to establish a secure connection.

Navigate to C:\Program Files\ModernMedia\UI+ and check the modification date of ModernMedia.Server.exe. The latest version will have a date of 9/10/20. Otherwise, an older version is in use. To update it, open UI+, click "Stop" to end the background server process, exit UI+ and delete ModernMedia.Server.exe from the folder. Run the installer again and ensure that ModernMedia.Server.exe has been extracted to the UI+ program folder. Finally, open UI+ to verify the server is running, and then check the Sports section in WMC.
Sorry it took a while to respond and let you know that worked. Thanks very much for your excellent support. :)

So - for me - I really don't see much in the way of enhancements in this version. (I do see that I'm getting the Rotten Tomatoes score now, which is cool.) But I'm sure many of the things you've improved helps others, so that's wonderful. And it's always great to see that work is continuing to be done on this valuable product.

As I indicated before, I use the Sports and Weather strips a lot, so any enhancements to that is appreciated. I am seeing this morning that NCAA FB has shown up in the tabs (although NFL is mysteriously missing). I assume that means there's work always being done on the MSN side to transition to present-day relevant sports. I don't know how much of that is your work and how much of the display content is determined by MSN. So here are my questions:
  • Assuming that the NFL tab will be returning very soon and today is just a temporary omission, I think the Sports strip is great. It seems to keep up adequately and accurately with ongoing scores. However I've noticed that once a game goes Final, there is no final score displayed. (It used to be I thought.) After a game goes Final, can't the final score be displayed for a while instead of just saying "Final". It would be a great reference for final scores, as well as live ongoing scores.
  • Are there any plans to enhance the Sports section? I know it's probably a lot of work, but in the early days of WMC, the Sports section was similar to what you're displaying now. However, you could tab down into the scores, actually select any game, and it would display the line score (e.g., by quarter), leading performer stats, etc. In addition, if the game was associated with a live game being played in the Guide, you could select it and it would take you to that channel to watch the game. I know, that's a big ask, but I really liked it when that capability was in the original WMC versions.
Also, I have a question about the EAS stuff you have in this version and determine if it has value to me. I have a Ceton cablecard tuner with Spectrum as my cable tv provider. In my area, they seem to like to send EAS warnings about every rain storm within 150 miles, lost child, etc. Now I'm not criticizing EAS value and importance, but it seemed like every day, sometimes multiple times a day EAS would display and scroll, taking over the entire display. It would overlay the ENTIRE screen to where I would have NO tv whatsoever and I couldn't get rid of the EAS scroll without rebooting - and then it would just come back again and scroll for hours - terrible. However, Ceton did put out a firmware that overrides the EAS display entirely (thank god). It works well and I never get EAS warnings disturbing my viewing experience now. But there are certain hoops I have to go through to implement this override every time I reboot my computer. It's not a big deal, takes a couple minutes, but still a PITA. So my question is, does your EAS additions in this version resolve this issue? If I just select your two EAS boxes, I don't have to go through the Ceton hoops upon reboot, MMUI+ will do the same thing automatically? That would definitely be an improvement in this version that would be of value to me.

Once again, thanks for your software and for your support.

Post Reply