Shows not recording randomly until rebooting the OS

jjacksqr

Posts: 16
Joined: Tue Jan 26, 2016 6:50 pm
Location:

HTPC Specs: Show details

Shows not recording randomly until rebooting the OS

#1

Post by jjacksqr » Sun Jun 20, 2021 9:44 pm

I didn’t see anything similar to this issue on the site. I’m using EPG123 and Windows 7. This started happening a couple of months ago sometime after updating EPG123. About every week or so recordings will not be successful. After rebooting the OS, recordings will resume. I tried updating EPG123 again to no avail. Is this a known issue and is there a fix?

grittree

Posts: 50
Joined: Tue Mar 18, 2014 3:09 pm
Location:

HTPC Specs: Show details

#2

Post by grittree » Sun Jun 20, 2021 9:58 pm

What does the WMC "history" say happened?

jjacksqr

Posts: 16
Joined: Tue Jan 26, 2016 6:50 pm
Location:

HTPC Specs: Show details

#3

Post by jjacksqr » Tue Jun 22, 2021 12:26 am

Where do I find WMC history?

User avatar
d00zah

Posts: 188
Joined: Fri Nov 07, 2014 7:20 pm
Location:

HTPC Specs: Show details

#4

Post by d00zah » Tue Jun 22, 2021 12:47 am

jjacksqr wrote:
Tue Jun 22, 2021 12:26 am
Where do I find WMC history?
Recorded TV > view scheduled > History

Kirben

Posts: 1
Joined: Wed Nov 04, 2020 5:18 am
Location: Australia

HTPC Specs: Show details

#5

Post by Kirben » Tue Jun 22, 2021 4:52 am

I'm having the same problem, closing and restarting Media Center makes no difference, it requires a reboot each time.
Nothing is listed in the History, so I have no idea what causes this problem.

jjacksqr

Posts: 16
Joined: Tue Jan 26, 2016 6:50 pm
Location:

HTPC Specs: Show details

#6

Post by jjacksqr » Tue Jun 22, 2021 7:24 pm

When this issue happens, the history does not list shows that were supposed to have recorded. After rebooting, shows that I set to record are in the history until the issue happens again.

stuartm

Posts: 629
Joined: Mon Nov 05, 2012 8:05 pm
Location: Longmont, CO

HTPC Specs: Show details

#7

Post by stuartm » Tue Jun 22, 2021 8:09 pm

So to be clear the shows are in the scheduled recordings list but then they don't record? Or, do you have shows (e.g. series requests) expected to record, but they are not even showing in the scheduled recordings list?

User avatar
d00zah

Posts: 188
Joined: Fri Nov 07, 2014 7:20 pm
Location:

HTPC Specs: Show details

#8

Post by d00zah » Tue Jun 22, 2021 9:09 pm

jjacksqr wrote:
Sun Jun 20, 2021 9:44 pm
This started happening a couple of months ago sometime after updating EPG123.
Just have to ask... did this ever work after installing EPG123?

Did you do a "clean start" setup of WMC when switching over to EPG123 using the instructions @garyan2 provided?

Run the transfer tool to convert old guide series IDs to SD IDs?

Old tuners still listed in channel config?

I've read of numerous problems from users who didn't follow the EPG123 setup instructions & this just sounds familiar.

jjacksqr

Posts: 16
Joined: Tue Jan 26, 2016 6:50 pm
Location:

HTPC Specs: Show details

#9

Post by jjacksqr » Tue Jun 22, 2021 9:39 pm

I don’t know if they were in the scheduled recording list, but I had set them to record. After rebooting, recording resumes as expected.
I followed the EPG123 instructions.

stuartm

Posts: 629
Joined: Mon Nov 05, 2012 8:05 pm
Location: Longmont, CO

HTPC Specs: Show details

#10

Post by stuartm » Tue Jun 22, 2021 10:17 pm

It will help to narrow down if we know whether they show in the scheduled to record list or not.

jjacksqr

Posts: 16
Joined: Tue Jan 26, 2016 6:50 pm
Location:

HTPC Specs: Show details

#11

Post by jjacksqr » Tue Jun 22, 2021 11:08 pm

Next time it happens I’ll check.

unclebun

Posts: 121
Joined: Sun Jul 09, 2017 11:06 pm
Location:

HTPC Specs: Show details

#12

Post by unclebun » Wed Jun 23, 2021 12:59 pm

Do you see error messages that the show didn't record?

jjacksqr

Posts: 16
Joined: Tue Jan 26, 2016 6:50 pm
Location:

HTPC Specs: Show details

#13

Post by jjacksqr » Wed Jun 23, 2021 5:47 pm

No error messages. WMA behaves as if it has not been requested to record anything.

jjacksqr

Posts: 16
Joined: Tue Jan 26, 2016 6:50 pm
Location:

HTPC Specs: Show details

#14

Post by jjacksqr » Sun Aug 29, 2021 7:09 pm

This issue happened again.
Attachments
DF90D2F3-AF8C-45F5-886B-2E60738384FD.jpeg
47FCA0CC-21C6-410F-85B3-064A102FF6B6.jpeg
969931FE-9EB5-42E1-9106-DB23FEB0F984.jpeg

jjacksqr

Posts: 16
Joined: Tue Jan 26, 2016 6:50 pm
Location:

HTPC Specs: Show details

#15

Post by jjacksqr » Sun Aug 29, 2021 11:07 pm

Note that a show that I requested to record was not recording.
Attachments
0D69AC18-42F4-4E1D-A00F-0FD0F568711E.jpeg

jjacksqr

Posts: 16
Joined: Tue Jan 26, 2016 6:50 pm
Location:

HTPC Specs: Show details

#16

Post by jjacksqr » Sun Aug 29, 2021 11:11 pm

Restarted system and it performed a chkdsk because of an inconsistency.
Attachments
1F356B5D-3A59-4AC6-AD1C-D85AC0D06014.jpeg

jjacksqr

Posts: 16
Joined: Tue Jan 26, 2016 6:50 pm
Location:

HTPC Specs: Show details

#17

Post by jjacksqr » Sun Aug 29, 2021 11:18 pm

After the restart, recording works again.
Note that schedule shows a red dot where a red dot didn’t show up when recording wasn’t happening.
Also, I tried to record the NFL game on 8/28. Since it didn’t record, it was scheduled for a replay on 8/29. Therefore, the system was aware that the recording was unsuccessful but no errors were displayed.
Attachments
96A4534A-1E8E-415D-881D-1168EF51A41E.jpeg
8A812DCE-F811-42A6-AF7E-354749F2DC5F.jpeg

User avatar
garyan2

Posts: 6577
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#18

Post by garyan2 » Sun Aug 29, 2021 11:24 pm

Click the History button. What does it say for the failed recording?

Sent from my SM-G965U using Tapatalk

- Gary
Keeping WMC alive beyond January 2020. https://garyan2.github.io

jjacksqr

Posts: 16
Joined: Tue Jan 26, 2016 6:50 pm
Location:

HTPC Specs: Show details

#19

Post by jjacksqr » Mon Aug 30, 2021 3:17 am

The recordings (the ones that didn’t happen) don’t show history. As if they were never set to record.

User avatar
CyberSimian

Posts: 511
Joined: Mon Jun 20, 2011 5:52 pm
Location: Southampton, UK

HTPC Specs: Show details

#20

Post by CyberSimian » Wed Sep 01, 2021 1:53 pm

jjacksqr wrote:
Mon Aug 30, 2021 3:17 am
The recordings (the ones that didn’t happen) don’t show history. As if they were never set to record.
Vista has a bug in the handling of its event log files that results in the most-recent few entries being missing from the WMC "History" panel, but these missing events do appear eventually.

The event log files can be configured either to create a new log file when the current one becomes full, or to wrap around to the beginning of the current log file (so you only ever have one log file). The bug is that this wrap-around gets out-of-step with the current-entry indicator. So when the WMC "History" panel displays the most-recent entries for WMC, the panel actually displays older entries. However, the new entries are created correctly, and they will appear in the "History" panel when a few more WMC entries have been added to the event log.

I don't know whether this bug also occurs in Windows 7. To avoid it, change the event log config so that it creates a new log file instead of wrapping round. (Of course, you will need to remember to delete older log files from time to time, to prevent your C: drive becoming full.)

-- from CyberSimian in the UK

Post Reply