Cannot get MKVs visible (and cannot play) in WMC

Having trouble playing all your different media types? Ask here!
Post Reply
leftcoastjayhawk

Posts: 2
Joined: Thu May 14, 2015 4:00 pm
Location: Left Coast

HTPC Specs: Show details

Cannot get MKVs visible (and cannot play) in WMC

#1

Post by leftcoastjayhawk » Mon Apr 23, 2018 11:47 pm

Recently I've decided to quit using the TMT5 plugin to Windows 7 WMC to play Blu Ray folders. (its been working fine for years, but recent Win 7 security updates have caused it to fail, apparently due to some kernal changes)

So I've decided to finally convert my Blu Ray folders to MKVs and play those in WMC. All the instructions on how to play MKVs in WMC are pretty out of date. Many references to a registry hack needed from a site that is no longer working (hack7mc.com). I have installed the latest Shark007 package (apparently successfully) which supposedly will do the job without a registry hack, but no joy. (The Shark007 forum registration system is broken and I cannot get on the forums there).

I've changed the splitter in the MKV tab to Haali's splitter, (as was suggested on some "how to use Shark007 to play MKVs in WMC how to websites...)restarted the PC, still no joy.

Anyone with any suggestions?

Thanks!

cwinfield

Posts: 575
Joined: Tue Feb 12, 2013 1:14 am
Location: Monroe, NC

HTPC Specs: Show details

#2

Post by cwinfield » Tue Apr 24, 2018 12:18 am

I tried to upload the .reg for you but it's forbidden, if you PM I'll send it directly to your email.

User avatar
Shark007

Posts: 203
Joined: Thu Feb 07, 2013 5:20 am
Location: Ontario, Canada

HTPC Specs: Show details

#3

Post by Shark007 » Tue Apr 24, 2018 1:16 am

When you install the Shark007 Codecs, it installs 2 Settings Applications.
Open the 64bit Settings Application using a right-click on the shortcut and choose Run as administrator
Press [Reset All] followed by the selection of the [x] SUGGESTED settings checkbox
Go to the mkv TAB and choose to [x] disable Media Foundation for MKV

Sorry to hear that you were unable to register on my forum.

That should get everything working for you.
Retain your sanity, use Shark007 Codecs

leftcoastjayhawk

Posts: 2
Joined: Thu May 14, 2015 4:00 pm
Location: Left Coast

HTPC Specs: Show details

#4

Post by leftcoastjayhawk » Tue Apr 24, 2018 8:23 am

Shark007, thanks for the help. Before coming back here, I did some more experimenting and found out that MKVs showed up in the WMC Movies section, even though I had placed them in the Recorded TV folder and expected to find them in the Recorded TV section of WMC. And they would play, but it took over 10 seconds for them to start playing after pressing the play button. Your recommendations have fixed the startup times. THANKS.

The option to Disable Media Foundation for MKV will not stay checked, however, but doesn't seem to help or hurt anything that I can tell yet.

For cwinfield and Shark: the registration problem for the Shark007 forums may be related to an error in the reCAPTCHA section. It is displaying an error message stating "reCAPTCHA V1 IS SHUTDOWN" and adds "direct site owners to g.co/recaptcha/upgrade"

Thanks for all your help. I have further questions about enabling/toggling closed captions, but I'll post those later after some more experimenting.

User avatar
Shark007

Posts: 203
Joined: Thu Feb 07, 2013 5:20 am
Location: Ontario, Canada

HTPC Specs: Show details

#5

Post by Shark007 » Tue Apr 24, 2018 9:42 am

leftcoastjayhawk wrote:The option to Disable Media Foundation for MKV will not stay checked, however, but doesn't seem to help or hurt anything that I can tell yet.
After checking my code, I realized I had this setting set to a Windows 10 feature only. This will be fixed in releases available moments from now.

leftcoastjayhawk wrote:Shark: the registration problem for the Shark007 forums may be related to an error in the reCAPTCHA section. It is displaying an error message stating "reCAPTCHA V1 IS SHUTDOWN" and adds "direct site owners to g.co/recaptcha/upgrade"
Thanks! (fixed now)
Retain your sanity, use Shark007 Codecs

Greenhorn

Posts: 8
Joined: Sat Feb 08, 2020 5:58 pm
Location:

HTPC Specs: Show details

#6

Post by Greenhorn » Sun Feb 09, 2020 6:31 am

I used lav filter and they play fine in WMC but in xbox360, it looks like poop (tranducing in 480p resolution?).

Stopped converting mp4/mkv to wtv just to view them via Xbox extender. Except for cablecard channels, I now use Plex to stream all my movies. Been busy encoding 3D blu ray collection to mkv and they look fantastic in 4K 3dtv, using Plex.

Post Reply